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Tutorial ID: IGET_GIS_006
This tutorial has been developed by BVIEER as part of the IGET web portal intended to provide easy access to
geospatial education. This tutorial is released under the Creative Commons license. Your support will help our team
to improve the content and to continue to offer high quality geospatial educational resources. For suggestions and
feedback please visit www.dst-iget.in.

IGET_GIS_006

Map Preparation using QGIS

Map Preparation using QGIS
Objective: To present given data in the form of a comprehensive map and to learn how to
edit layer symbology in QGIS.

Software: Quantum GIS 2.0.1-Dufour

Level: Beginner

Time required: 3 Hours

Prerequisites and Geospatial Skills:

1.

QGIS should be installed on the computer.

2.

Familiarity with the layout of QGIS is preferable.

3.

Should have completed Exercise ID: IGET_GIS_001 and IGET_GIS_005

Reading
1.

Sutton, T., Dassau, O., & Sutton, M. (2009). A gentle introduction to GIS. Chief
Directorate: Spatial Planning & Information, Eastern Cape.

Tutorial Data: The data required for this tutorial can be downloaded from IGET_GIS_006.
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Introduction
Map is a graphical representation of a particular area or whole earth on a flat surface. This
flat surface may be a paper or a cloth etc. A very common output of any GIS/Surveying work
is map. A map conveys more information than words, therefore a good map portraits your
results and efforts in a better position. Cartography is a branch of art and science, which
deals with the map making. There are a wide variety of maps available topographical,
geological, thematic, climatic, military and guide maps are few among many. The main
objective of this tutorial is to guide the user how to prepare a basic map in QGIS. In this
tutorial we will learn how to label and edit the symbology of various features to create a map
showing hospitals and bus stops of south Pune. The data1 supplied with this tutorial is an
output of IGET_GIS_005: Digitization tutorial. The toposheet of South Pune used in many
tutorials of IGET portal is prepared in QGIS. We will cover how to create a full pledge
topographical map in advance map making tutorial, at this point of time this tutorial
concentrate on basic foundation.

1. Start QGIS- Dufour and open the map layers via the menu Layer → Add Vector Layer.
In the next window, click on ‘Browse’. Navigate to the tutorial data folder with the
vector layers in the popup window. Change the layer type to ‘ESRI Shapefiles’. Select
all the layers by clicking on one and pressing CTRL+A. Click ‘Open’ for both windows.
1

2. Now all the layers will be loaded to the map canvas and will be listed under the Layers
section alphabetically in descend order. This is because QGIS loads the files the order
in which they are stored on the computer.

1

The Data supplied is not a validated data. It is necessary to carryout topological and other corrections before using
it for any analysis purpose. The error identification, removal and establishment of topology will be covered in data
validation tutorial.
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2

Note: The colour scheme of features in your map canvas may be different from the above
figure.

3. Now rearrange the layers in such a way, all point features are on top to line features
and line features over the polygon features. This can be done by selecting the layer
and hold the left mouse button over it (the mouse cursor will turn into to a

double

headed arrow) and then dragging them up or down.
3

4. Let’s start the map preparation by setting the colours for the base polygon layers.
Double-click on the ‘Urban Areas’ layer to open the ‘Layer Properties’ window and
select the

tab.
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5. While setting the colours for polygons, it must be remembered that they are larger
than most other features in the map and their presence is already felt by virtue of their
size. We must therefore assign light and pastel colours to make sure the polygons fall
into the background.

5

6

6

6. Click

‘Colour’ button and select the preset ‘Pink’ for this layer.

This is a light colour but it may still be too strong for our map. We can dilute it by
decreasing the saturation. Change the saturation from 85 to 40.

Click ‘Okay’

on both boxes.

7. Now you will notice the urban Areas colour turned to light shade of pink.
7

8. The colours can be taken from the preset ‘Basic colors’ palette. To make light and dark
grey, select White or Black and change the Shade using the slider as shown for the
5
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light brown below.
8

9. Use the above same method to set the colours for all other the classes as shown below.
9

10. Now the map should looklike near to the below figure, however it depends uopon your
assorted colour code.
10
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11. Let’s change the border colour of the ‘Urban Areas’ layer. Double-click on it to open
the ‘Layer Properties’ window and click on the ‘+’ button located right side to ‘Fill’
under ‘Symbol layers’ in ‘Style’ section. Now select the ‘Simple fill’ under ‘Fill’, click
the

button which is located right side to it and select red from

the colour palette. Set the border width to 0.4mm as shown below and click on ‘OK’.
11

12. Take a look at the ‘Open Scrub’ and ‘Urban Greens’ layers. They both have the
somewhat similar colour. We can differentiate them by simply changing the colours,
sometimes patterning yields a better visualization then simply changing colours. Open
the ‘Layer Properties’ window of the ‘Urban Greens’ layer
13

14
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13. Click on the ‘

Add Symbol Layer’ button on the bottom left of the window. This

will add a new symbol layer under ‘Symbol layer’ section. Select it and change the
‘Symbol layer type’ to ‘SVG Fill’.

14. Use the

symbol form the SVG symbols, change the colour and texture width as

shown in the above figure for the ‘Urban Green’ layer and click ‘OK’. Use the same
method to set your desired symbology to other polygon layers.
14

Urban Greens

Open Scrub

15. Now that we’ve set the symbology of the polygons, we will start with the lines. For the
roads we will use the colour orange with a red border.

16. Double-click on the ‘Roads’ layer to bring up the

‘Layer Properties’ window. To

emulate the effect of having an orange fill with a red boundary, we will use two symbol
layers. The thinner orange layer will be stacked on top of a thicker red layer.

17. Use the

‘Add Symbol Layer’ button to add another symbol layer. Select the

upper layer and change its colour to ‘orange’ and its width to ‘0.7mm’. Set the lower
layer with a width of ‘1mm’ and colour ‘RED’ and click on ‘OK’.

18. For the ‘Highways layer’ we will use the same approach. Change the layer symbol to a
‘red’ line of width 3mm stacked on a black line with width 3.2mm.
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16
17

19. If you look at the road or highway junctions you will notice that the intersections are
not contiguous (as shown below). To smoothen the intersections, open the ‘Layer
Properties’ window of Highway layer and from the

menu (locate just

above the right-bottom of the window) select ‘Symbol levels…’. In the popup window,
check ‘Enable symbol levels’. Click ‘OK’ on both windows. Do the same for Road
layer.
19

20. The point layers are currently symbolized by coloured circles. Although they are easily
9
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identified when the circles replaced with more pictorial/descriptive symbols. Double
click the ‘Bus stop’ layer and select the ‘Simpler Marker’ under ‘Symbol layers’.
Change the ‘Symbol layer type’ to ‘SVG Marker’ and use the bus stop icon and
change the other fields as shown below and click on ‘OK’.

21. Follow the above same procedure to change the symbology of ‘Hospitals’ layer to

22. Click the ‘Zoom Full’

.

button to view the entire map. Our map should now look like

below and ensure the layer order under Layer section as same as below.

22
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23. Now we label the point layers using the names provided in the attribute table. Rightclick on the ‘Hospitals’ layer and select ‘Open Attribute table’. Here we see that the
name of the hospital associated with each place mark in shape file. You will a similar
table for ‘Bus stop’ layer also.
23

24. To label the features we will use the Label engine provided in the Label Toolbar. Look
for the toolbar that looks like this

above the map

canvas. If the tool bar is not present activate it via the menu View → Toolbars → Label.

25
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25. Select ‘Hospitals’ layer under ‘Layers’ section and click on

button. In the ‘Layer

label settings’ popup window check the option ‘Label this layer with’ and select
‘Name’ from dropdown menu next to it and Click ‘OK’. Do the same for the ‘Bus
Stops’ layer.

26. This is how the labeled features will appear on the map:
26

27. To prepare a map use the Print Composer. Open it via the menu Project→New Print
Composer. You can assign a unique print composer title. Call it SouthPune and click
on ‘OK’.
27

28. Change the size of the paper to ‘A2 (420x594mm)’ using the Composition tab located
right side in the composition window and click on

‘Zoom Full’ in the tool bar.
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29. Click on the

‘Add new map’ button in the toolbar and place the mouse pointer

on the top-left corner of the composers’ workspace and hold the left mouse button to
drag across the whole page to create the map.
29

30. The map will be displayed in the composer’s workspace generally it would be at a high
or low scale than the publishing scale. In this tutorial 1: 15000 will be considered as
publishing scale, to set this scale click on ‘Item Properties’ tab and type ‘15000’ in
the ‘Scale’ field and press ‘Enter’ in the key board.
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Task 1: If you want to publish the map on 1:7500 scale, what paper size should you choose?

31. Click on the

‘Move Item Content’ button in the tool bar, and drag the map to a

suitable position like shown below.

32. A map must contain Title, Author, Legend, Date, Orientation and Scale. You can
remember this by an acronym TALDOS. These are the minimum necessary elements
for any map.
33. Add the title by clicking on the

‘Add

New Label’ button and then clicking on a

location. Once it is placed, click and drag the corners to increase the size.
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34. Click on the Label box

in ‘Item Properties’ and in the entry box enter the title of

the map as ‘Hospitals and Bus-Stops of South Pune’. Click on the ‘Font’ button to
change the font style and size to ‘Bold’ and ‘36 pts’ respectively. Set the horizontal
and vertical alignment to ‘Centre’ and ‘Middle’ respectively. Now resize the
rectangle box to fit the title text.

34

Task 2: Use the Add new Label option to add authors name and date of publish/surveyed the
right bottom of the map.
15

IGET_GIS_006

Map Preparation using QGIS

35. To add legend click on the

‘Add new Legend’ button in toolbar and place the

mouse curser over a suitable place in the workspace and click on left mouse button to
place legend.

35

Task 3: Explore how to adjust the font and symbols in the legend? Hint: It can be adjusted by
selecting the legend and clicking on the ‘Item Properties’ tab.
36. To add the scale bar, click on

‘Add new scalebar’ button and place it on the map.

Set the ‘Segment Size’ to 500 and the ‘Map units per bar unit’ to 1 and all other values
as shown below figure. These are two important parameters:
a.

‘Segment Size’ – This defines the length of the scale bar segment in map units
(in our case it is metres).

b. Map units per Bar Unit – This translates the map units to the scale bar units.
Since they both are meters we will keep this as 1.
36

37. For the north arrow, click on

‘Add image’ button. Place it in the top right of the
16

IGET_GIS_006

Map Preparation using QGIS

map. From the ‘Item Properties’, click on ‘Search Directories’ to select one of the
north arrows.

37

38. For more adjustments, click on ‘Rendering’ in ‘Item Properties’ tab. Slide the
‘Transparency’ slider down to five.

39. Now click on the center of the map to select the whole map extent. Now ‘check’ the
check box of ‘Frame’ under the ‘Item Properties’. The map will look like below
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40. Now save the map composer by clicking
clicking the

‘Save’. Now export the map to a Pdf by

‘Export to PDF’ button. Navigate to a suitable folder, name the file

as ‘SouthPune’ and press ‘Save’.
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