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Supervised Classification using SAGA
Objective: To create a land use and land cover map of a region by the Supervised classification method using SAGA.
Software: SAGA GIS
Level: Intermediate
Time required: 4 Hours
Prerequisites and Geospatial Skills:
1.
2.

SAGA should be installed on the computer.
Student must have completed exercise IGET_RS_001, IGET_RS_002, IGET_RS_003, and
IGET_RS_007.

Readings
1.

Tempfli, K. (editor) , Huurneman, G.C. (editor) , Bakker, W.H. (editor) , Janssen, L.L.F. (editor) ,
Bakker, W.H., Feringa, W.F., Gieske, A.S.M., Grabmaier, K.A., Hecker, C.A., Horn, J.A., Huurneman,
G.C., Kerle, N., van der Meer, F.D., Parodi, G.N., Pohl, C., Reeves, C.V., van Ruitenbeek, F.J.A.,
Schetselaar, E.M., Weir, M.J.C., Westinga, E. and Woldai, T. (2009) Principles of remote sensing : an
introductory textbook. Enschede, ITC, 2009. ITC Educational Textbook Series 2, ISBN: 978-90-6164270-1. pp. 280-312. Full text

Tutorial Data: The LandSat TM image required for this exercise may be downloaded from this link:

SAGA 2.08 can be downloaded from this location:
http://sourceforge.net/projects/saga-gis/files/SAGA - 2.0/SAGA 2.0.8/saga_2.0.8_bin_msw_win32.zip/download
After downloading the file, unzip it to a convenient location.
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Introduction
In the previous tutorial, i.e., ‘IGET_RS_007: Unsupervised Classification’, we classified the images using the
unsupervised method. There are limitations in using this method since we don’t have full control over the
computer’s selection of pixel into clusters. In supervised classification, the user will select a group of pixels belongs
to a particular land use / land cover known as training areas or training sites. Based on the pixel values in the
training areas the software will create spectral signatures and the statistical information like range, mean, variance
etc., of all classes in relation to all input bands. This information has been used to categorize each and every pixel
in the image into corresponding land use and land cover class based on the classification algorithm used. Maximum
Likelihood (ML), Minimum Distance to Mean (MDM) and Parallelepiped classification algorithms are most
commonly used for supervised classification. For brief introduction about the algorithms please read section 8.3.4
‘Classification algorithms’ in Principles of remote sensing: an introductory textbook of ITC, 2009.
Since, the supervised classification method involves selection of training areas, the user should have a good idea
about different land cover classes existing in the study area. This knowledge can be acquired through field
verification and other ancillary data. In this tutorial we will use the same LandSat TM image supplied to you for
unsupervised classification.

This image was downloaded from the

USGS

earth

explorer website:

http://earthexplorer.usgs.gov/
1.

Open SAGA Interface → Load the LandSat images into SAGA by clicking on the

‘Load File’ button

or via ‘File → Grid → Load’. Select the ‘Subset_LandsatTM_8feb2011.tif’ images and click ‘Open’. This
will import the image into SAGA.
1

2.

We start by creating RGB composites of bands using different combinations to easily identify the
different land cover types by visual interpretation. Use ‘Module → Grid → Visualisation → RGB
3
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Composite’ to create the RGB composites of 4, 5 & 2. Refer steps 3 – 8 from ‘IGET_RS_007: Unsupervised
Classification’ for help in creating ‘RGB composites’ and renaming the composites.
2

3.

Now open the composite in a Map window, by double click on the ‘Composite 452’. This combination
highlights urban areas with different shades of blue. Scrub land appears green and vegetated areas appear
red. Many more inferences can be made about the land cover from the false colour composite.
3

4.

4

Create another false colour composite with the band combination 7, 4 & 2, and a true colour composite
321. Name them accordingly.

5.

Overlay these layers on the ‘Composite 452’ layer by double-clicking on the layer in the data list, and
then selecting ‘Composite 452’ from the list, click ‘OK’.

6.

Go to the

tab where you will see the list of maps and the layers loaded in each map. You can

turn the layers on and off by double-clicking on them (Invisible layers are placed in [ ] brackets). You can
rearrange these layers by clicking and dragging them above or below each other, when you need.
4
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Use this to learn which land cover / land use types are represented by which colours in different band
combinations.

8.

In SAGA, the sample collection is done by using shapefile polygons. Create a shapefile layer via the
‘Modules → Shapes → Construction → Create New Shape Layer’. Enter ‘Signature_Samples’ in the
‘Name’ field and change the Shape Type to ‘Polygon’. Leave the default values in the other three fields.
Click ‘Okay’.

8

9.

A polygon named ‘Signature_Samples’ will be created and placed in the ‘Data’ list under the Shapes.
Add this polygon layer to the map on which you would like to create the sample polygons by double
clicking on the ‘Signature_samples’ shape file → Now select ‘Composite 452’ from the popup window
i.e., ‘Add layer to selected Map’ → ‘OK’.

10. In order to pick up training areas, we have to enable the editing mode of shape file. To start editing,
Right-click on ‘Signature_samples’ shapefile → Edit → Add Shape or Select the

Action button

from ‘Tool Bar’ or from ‘Main menu bar → Map → Action’ and then Right click on the map → Add
Shape. This will change the cursor to a ‘+’ sign.

5
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11. Zoom in to the forests in the left of the image. Create the sample shape by clicking around a bright red
forest patch in ‘Composite 452’. When you are outlining the feature be precise and select as many similar
looking pixels as possible within a single polygon.
12. When you are done with outlining, simply ‘Right-click’ on mouse button to stop signature acquisition. To
save this single polygon as a sample ‘Right-click → Edit → Uncheck ‘Edit Selected Shape’ and click ‘Yes'
on the pop up window. This will save the shape to the polygon layer.
12

13.

The signature sample is listed in the polygon attribute table. To open the attribute table: ‘Right-

click on polygon layer → Attributes → Table → Show’. The attribute table will open with two fields – ID
and Name. By single / double click on the corresponding cell you can able to change vales in table. Type
the name as ‘Forest’. The ID field is filled in as 0, change this to the corresponding class number as per
the following table on right side. For ‘Forest’ the corresponding ID is ‘6’.

Class
Builtup

Number
1
6
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13

Agriculture

2

Scrub

3

Open Scrub/Barren

4

Water

5

Forest

6

14. It is obvious that the same land cover class will have different signatures in different places. For example,
the forests on slopes facing away from the sun will be darker. Though they look different they will all be
placed under the same class of Forest.

14

Note: While creating sample shapes, draw the boundary on the inside edge of a feature. This will ensure that a
purer signature is picked up from this sample. Make sure that a signature contains only pixels of that one
class. If other class pixels are present it will dilute the quality of the signature.
15. A few things to keep in mind while digitizing the signatures in SAGA:
a. The Right-click → Edit operations may not always work via the Maps tab and the Map Window.
At this time you have to select
b.

Action tool before doing it again.

If you notice no tool bar on the under main menu, which contains Action, Zoom, Pan and other
tools, click on Map window to access them.

16. We must therefore pickup signature for every variation of forest for accurate classification. Zoom in to the
shaded forest, then select ‘Forest’ row from the attribute table. Be sure that the row is highlighted in blue
color and as well as the first Forest polygon in yellow. Now navigate to the forest area in shadow, looks
Dark red in ‘Composite 452’ in the map window.
17. Now, click on

Action and then right-click on the Map → select ‘Edit Selected Shape’→ You can

notice the first forest shape changed in to editing mode →Once again right-click on the Map → Select ‘Add
Part’ → create a signature for forest area in shadow as well → ‘Right click’ to finish the polygon. Repeat
7
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this process to cover all variations of forest. Save the shape by Right-click (once/twice) → Edit → Uncheck
‘Edit Selected Shape’. Now you can see that all forest variations are add to the same signature ‘Forest’.
16

18. The boundaries of the shapes may be dark, making it difficult to see. Changing its colour to a bright color
will increase its visibility as seen in the screenshot below. Change the ‘Edit Color’ via the

tab

of the shape layer. After clicking ‘Apply’, the colour may not change immediately but will change when
creating the next shape.
18
18

19. Similarly use Add Shape option to create a new land cover / land use
class and Add part option to pickup variation of it. Now collect
signatures for the rest of the classes presented in the table under step 13.
19
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20. Once you are done with the signature collection, now you are ready to run Supervised classification
module. Open it via ‘Modules → Imagery → Classification → Supervised Classification’ module. Set the
values for Grid system, Grids, Training Areas and Class Identifiers as shown below.
20

a

b

c

a. The ‘Grid system’ entry will be the grid system of our input data set. For the >>’Grids section’,
click on the

button to the right of the field. In the dialogue popup window, we select the 7

bands of the LandSat Image and click on the

button. This will transfer the layers to the

right which indicates that they will be used by the module. Click ‘Okay’.

9
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b

b.

‘>>Classification’ as ‘[Create]’. The Quality option allows us to create an image which describes
the quality of the classification for every pixel. The image values vary with the type of
classification, here will select ‘[not set]’.

c.

The ‘>>Training Areas’ input is the shapefile containing all the signature shapes. Set it as
‘Signature_Samples’.

d. The ‘Class Identifier’ is the field with which we differentiate the classes. The classes will be named
according to this field. Set it as ‘ID’ or ‘Name’. By using this text field we can easily identify and
relate the sample area description with the class.
e.

Set the Method option as ‘maximum likelihood’ and leave others as default.

f.

Click on ‘Okay’ to proceed for maximum likelihood supervised classification.

21. The classified image will look something like the image below. The image has been split into 6 classes, with
each class coming from one set of signature polygons.

10
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21

22. We can assign colours and class names via the lookup table. Select the image from the list and open the
lookup table by clicking the

button via the

tab.

22

23. The lookup table will open with 5 columns - COLOUR, NAME, DESCRIPTION, MINIIMUM, and
MAXIMUM. Rename the NAME entries to the class names. Click on the colour box and select a colour
from the palette or create your own.

23

24. After renaming the all the classes, click on ‘Okay’ and then ‘Apply’ in the

tab.
11
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25. Overlay the reclassified image onto the satellite image. Make it transparent or invisible, and compare the
classified image to the satellite image.
25

26. There may be parts of the image which are wrongly classified. This mostly happens if the signature of one
class is similar to that of another class. This can be fixed by refining the signatures and run the
classification again.
27. For example, in the classification below, the forest pixels have been wrongly classified as agriculture.
Compare the picture on the left to the satellite image on the right. We may rectify this by creating
signatures samples from these pixels and then classifying them as forest. However we can also rectify this
issue by knowledge base classification approch, which will cover in advanced remote sensing tutorials.
27
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28. The supervised classification may not be completely accurate for the first time. With some refinement in
the signatures the classification quality will improve.
29. We will now create a map of this image by opening it in a new map window. Select the map from the
tab and then click ‘Show Print Layout’

button in the toolbar located below the Main

Menu. This will open a window with the map layout.

29

30. Change the name of the map via the

tab. In the Name field type ‘Land-Cover Classes’,

press Enter, and then click Apply.

31. The fields of the

tab are different for the map and for the image. Selecting on the map will

enable you to add or remove map features like scale and legend.

13
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31

32. To adjust the map extent, or to represent only a particular region on the map, we must zoom in and out
using the Map window instead of the Map Layout window. This is linked to the Print layout window will
automatically adjust the zoom to the Map window extent.
Eg. The map below is focused on Pune and the print layout has got the same extent.

32

33. To view the final map, click the ‘Print Preview‘

button.

14
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34. Click the ‘Close’ button to exit the print preview or ‘Print’ to print the map as it is.
35. We can save this map either by printing as a PDF file or by exporting it as an image (Right Click → Save
as Image).
35

36. Use a suitable name for the map and format, then click ‘Okay’. In the next window that opens, some
parameters will be given regarding the map. Uncheck ‘Save Georeference’ and ‘Save KML File’ and
leave the other parameters as the default values. Click ‘Okay’. The image and the legend get saved as
separate files. The saved map will look like this:

36
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37. We will learn how to assess the quality of our classification in the next tutorial IGET_RS_009.
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